+ Reply to Thread
Results 1 to 4 of 4

Thread: Spark Knock Issue

  1. #1

    Spark Knock Issue

    I need some input on a spark knock issue under light acceleration for my 2003 4.8, manual trans silverado. Went to 89 octane. Changed PCV, plugs, clean air filter. Will a bad knock sensor cause it with no CEL? Been chasing this for years. Is the winter gas causing this. I forgot what it is but the octane rating changes because of temp change. i think. Thanks and please give me some kind of help.

  2. #2
    Join Date
    May 2009
    Location
    hot & windy
    Posts
    1,124
    bump for similar...
    5.3 manual; getting random hesitations under any throttle input/gear/speed. various durations & intensities but frequent.
    i've ran a tank of HEET + storage stabilizer (just had some left), then a tank of 93 with seafoam. i've replaced the fuel filter & pulled/cleaned the injectors.
    no CEL or codes (other than a persistent P0446 whenever i'm below 1/2 tank).
    00 FRC - just top end, exhaust, and a hot-air intake
    99 Sierra - 5.3 / 5spd
    ↓ click the pic for the build ↓

  3. #3
    Join Date
    May 2009
    Location
    hot & windy
    Posts
    1,124
    even updated-er update: unplugged the knock sensors & drove around. does the same thing.
    spark plugs & wires look good (plugs have 20k on them since new with cam spring last year).
    is this pointing to coils?
    00 FRC - just top end, exhaust, and a hot-air intake
    99 Sierra - 5.3 / 5spd
    ↓ click the pic for the build ↓

  4. #4
    Join Date
    May 2009
    Location
    hot & windy
    Posts
    1,124
    could i zip-tie on the coils from my LS1 (square style vs the round LM7 ones) to see?
    they have the same main harness connector
    00 FRC - just top end, exhaust, and a hot-air intake
    99 Sierra - 5.3 / 5spd
    ↓ click the pic for the build ↓

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts