+ Reply to Thread
Results 1 to 3 of 3

Thread: 00 Silverado 5.3 automatic transmission problem

  1. #1

    00 Silverado 5.3 automatic transmission problem

    My truck canít go any faster than 35 m/h it switches first and second gear but doesnít switch to third gear the speedometer works good the reverse works so I replaced the fuel filter and nothing happened then I replaced the output speed sensor and still the same now I want to replace the input speed sensor but I canít find it around the transmission does any body can tell me where is located ?
    Please .

  2. #2
    Join Date
    Aug 2011
    Location
    New Port Beach, CA.
    Posts
    54
    It maybe stuck in limp home mode. I know if there is a problem with the tps on the 2003 it will only allow you to go a max of 35 with very little power.
    6.0 MAX Blown

  3. #3
    Join Date
    Aug 2011
    Location
    Ellsworth Air Force Base, SD
    Posts
    143
    So how is this fixed? I am having the same issue, truck is running fine but when you start driving it will not shift. Forward, reverse.... great. It will burn the tires off but will not shift. If it is tps will unplugging and replugging fix this. Is there a live data read out that I can plug into the OBDII and see if something is off. Need help.
    1994 Chevy C1500 RCSB 05' DBW 5.3 Conversion Complete
    My build

    Coming soon ....... Full Repaint, 214/220 Cam, Yukon Posi with 3.73's, remove body lift

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts