+ Reply to Thread
Page 9 of 10 FirstFirst ... 7 8 9 10 LastLast
Results 81 to 90 of 95

Thread: 98 2dr 4wd tahoe LS swap

  1. #81
    [QUOTE=2drhoe;523381]she lives!!!!/QUOTE]

    Without a video it didn't happen! Inquiring minds want to see!

  2. #82
    Join Date
    Jan 2014
    Location
    Las Cruces NM
    Posts
    209
    Have you got to drive it yet?
    97 RCSB . 2WD . 5.3 . 4l60E . E-FANS . PNP 706s . TSP 228R . 3600 STALL . HD2 . VETTE SERVO . 3.73s . 2" DROP
    TURBO IN THE WORKS

  3. #83
    yeah i have driven it about 4 times... prolly put 50 miles on it...had a few problems but worked them out i think...

    had a bad ground for my interior stuff and gauges.... that little ribbon ground from the pass frame to the body had to go... i took it off and it was painted under it haha.. replaced it with a 4 gauge stinger cable and all is well....
    heard a whining noise at low speeds while driving... turns out my fluid in the PS pump was a tad low causing aeration i think...... other than that all is well........ runs like a bat out of hell....the guy i bought my engine/ecm from put a light tune in it when he installed the base tune.. next is getting a few more bolt ons then a cam and a tune... I plan on swapping a ls6 intake on it and beehive springs with a 220/220 cam. and a new fuel pump cause its bound to go out soon anyway..
    98 Tahoe 4WD. 2002 5.3L LS swap.. Lowered on shackles and keys. 22" Escalade rims with custom SS centercaps, 2 tone red and gunmetal paint with silver pinstripe.SS front bumper cover.Rear roll pan. Street scene mesh grille inserts.debadged and demoulded.6K HIDs and hidden yellow fogs.Billet bowtie.K&N intake system. Flexalite Efans.Dual optima batteries. Pacesetter shorties High Flow cats. Flowmaster muffler with single exit exhaust. Escalade Seats and console. SS headrests. Remote Twin turbo build in progress!!!

  4. #84
    Join Date
    Jan 2014
    Location
    Las Cruces NM
    Posts
    209
    Did you use the 5.3 p/s pump? If so, did it have hydroboost? Reason I ask is wondered how you capped the second return fitting.
    97 RCSB . 2WD . 5.3 . 4l60E . E-FANS . PNP 706s . TSP 228R . 3600 STALL . HD2 . VETTE SERVO . 3.73s . 2" DROP
    TURBO IN THE WORKS

  5. #85
    Join Date
    Mar 2013
    Location
    Long Beach California
    Posts
    639
    Quote Originally Posted by Chevydillan View Post
    Did you use the 5.3 p/s pump? If so, did it have hydroboost? Reason I ask is wondered how you capped the second return fitting.
    just cap it and your good to go. i tried using a t fitting to split it and no go. causes airation. i capped it and dumped all of it to the main return and no more whining.
    Like Tumbler in "Gone in 60" I'll drive anything with wheels or without

    My 95 ECSB LQ9 build thread - http://www.ls1truck.com/forums/lsx-t...to-95-obs.html
    CALI LEGAL ENGINE SWAP!
    Stock 03 LQ9, DBW, 95' 4l80e w/ Transgo shift kit, 2010 50# GM injectors, 2800 Circle D stall, Spectre CAI, Upgraded trans cooler, Home-made E-fans/shroud, Dual EP-381 fuel pumps w/Home-made hotwire kit
    NEXT ON LIST: Dual Battery setup, CAM/Valvetrain upgrade, Build my own rear mount turbo, TRU-TRAC, HIT THE STRIP!!!

  6. #86
    I dont have hydroboost.. I looked on the back of my 5.3 pump and there were only 2 fittings. Ive been driving the truck a little bit over the past few days and I have had a CEL. hooked up to a scanner and I have 4 codes...

    p0135 02 heater
    p0332 Knock sensor
    p0342 Cam sensor
    p0343 Crank sensor

    What in the world would cause all of those codes at once? Seems to run the best it has ever run.
    98 Tahoe 4WD. 2002 5.3L LS swap.. Lowered on shackles and keys. 22" Escalade rims with custom SS centercaps, 2 tone red and gunmetal paint with silver pinstripe.SS front bumper cover.Rear roll pan. Street scene mesh grille inserts.debadged and demoulded.6K HIDs and hidden yellow fogs.Billet bowtie.K&N intake system. Flexalite Efans.Dual optima batteries. Pacesetter shorties High Flow cats. Flowmaster muffler with single exit exhaust. Escalade Seats and console. SS headrests. Remote Twin turbo build in progress!!!

  7. #87
    Join Date
    Jan 2014
    Location
    Las Cruces NM
    Posts
    209
    Heres a good read for the knock sensors
    http://m.ls1tech.com/forums/showthread.php?t=1592341
    I'd say probably just a bad o2 sensor for that one
    For the other 2 they are both cmp codes I'd try switching the 2 outside wires. I know you've had trouble with that sensor before. Couldn't hurt.
    97 RCSB . 2WD . 5.3 . 4l60E . E-FANS . PNP 706s . TSP 228R . 3600 STALL . HD2 . VETTE SERVO . 3.73s . 2" DROP
    TURBO IN THE WORKS

  8. #88
    Join Date
    Jan 2014
    Location
    Las Cruces NM
    Posts
    209


    Here is my cam sensor plug. A is on the far right.
    97 RCSB . 2WD . 5.3 . 4l60E . E-FANS . PNP 706s . TSP 228R . 3600 STALL . HD2 . VETTE SERVO . 3.73s . 2" DROP
    TURBO IN THE WORKS

  9. #89
    Join Date
    Sep 2011
    Location
    Atlanta Ga
    Posts
    692
    nice truck man! i did the same thing some time back. everytime i hop back on this forum i regret letting it go! that wiring is a pain i married both harnesses as well in my 96. pretty detailed write up in my build might help.
    96 2 Door Tahoe 4wd / 5.3 Swap / CAI / Tune / Pacesetter LTs / Magnaflow / LED Dash / Novak A/C Bracket /


    http://www.ls1truck.com/forums/lsx-t...ders-pics.html

  10. #90
    Join Date
    Nov 2011
    Location
    New Brunswick, Canada
    Posts
    123
    Great looking truck man! Good job

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts