+ Reply to Thread
Results 1 to 6 of 6

Thread: New and lookin for some answers about my transmission.

  1. #1

    New and lookin for some answers about my transmission.

    I have a 2001 Silverado 1500 and my transmission is not shifting past 2nd gear. 1st to 2nd is fine but it won"t go any further. Any suggestions?

  2. #2
    Join Date
    Feb 2007
    Location
    Sallisaw OK
    Posts
    2,230
    Welcome to the site, i can tell ya redheartbeat knows what he is talking about, he has fixed my vehicles just by telling me what to do.
    1996 gmc ext cab short bed
    6.6L 4l80e
    MY GARAGE

  3. #3
    Join Date
    Nov 2003
    Location
    Denton Texas
    Posts
    20,689
    If you have 1st and 2nd gears and can feel the shift between the two, chances are that you have burned out the clutches in the trans or simply have a 2-3 shift solenoid burned out or plugged up. If your truck starts out in 2nd gear and you don't get a 3rd gear shift you likely have an electrical issue in the power supply to the transmission. From your description it sounds like the solenoid is burned out or the clutches are gone. Let it set overnight and then drop the pan. If it has a lot of brown settlement in the bottom of the pan, your clutches are gone most likely. If only a light amount of settlement you may be lucky and just have a solenoid issue. I would take it by a transmission shop first and have them put their scanner on it to see if they can diagnose it for you and get a quote for the repair. Most places won't charge for the diagnosis and you will be able to make your decision which way to go in the repair process.
    See my truck data in the "My Garage" section here... http://www.ls1truck.com/forums/my-ga...tml#post191709

  4. #4
    Join Date
    Mar 2007
    Posts
    1,729
    Quote Originally Posted by RedHeartbeat View Post
    If you have 1st and 2nd gears and can feel the shift between the two, chances are that you have burned out the clutches in the trans or simply have a 2-3 shift solenoid burned out or plugged up. If your truck starts out in 2nd gear and you don't get a 3rd gear shift you likely have an electrical issue in the power supply to the transmission. From your description it sounds like the solenoid is burned out or the clutches are gone. Let it set overnight and then drop the pan. If it has a lot of brown settlement in the bottom of the pan, your clutches are gone most likely. If only a light amount of settlement you may be lucky and just have a solenoid issue. I would take it by a transmission shop first and have them put their scanner on it to see if they can diagnose it for you and get a quote for the repair. Most places won't charge for the diagnosis and you will be able to make your decision which way to go in the repair process.
    Pay attention to this man dude....I told him my Trans problem the night it happened (1500+ miles away from him) and he told me EXACTLY what was wrong....just confirm it later when I took the trans apart !

  5. #5
    Join Date
    Aug 2010
    Location
    Cannon Falls Mn.
    Posts
    215
    Welcome

    99 4x4 5.3 NELSON TUNED / 02 Ls1 CAM / 02 Ls1 "241 Heads" Port/Polish milled .045" / 03 INJECTORS / AIR RAID JR. INTAKE / PORTED THROTTLE BODY / TR55's / EGR DELETE / E FAN's / CAT DELETE / EXHAUST DUMPED

    Headers, Transgo HD2, 3200 stall, 4.56 gears coming soon.....

  6. #6
    Join Date
    Dec 2009
    Posts
    129
    Welcome aboard. Sounds like exactly what mine did & it was the clutches, as well. Got it built right, for now.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts