+ Reply to Thread
Results 1 to 7 of 7

Thread: Throwing some codes.

  1. #1
    Join Date
    Sep 2005
    Location
    Austin Tx.
    Posts
    13,396

    Throwing some codes.

    Well I just got the 5.3 in and after putting about 7 miles on it I threw 3 codes. Im only running longtubes and ORY right now.

    - PO151 HO2S CIRCUIT LOW VOLTAGE BANK 2 SENSOR 1
    - P1153 HO2S INSUFFICIENT SWITCHING BANK 2 SENSOR 1
    - PO507 IDLE SPEED HIGH

    I think the first two are related to oxygen sensor, I replaced the one on the driver side, so its brand new. One on the pass. side is from the V6.

    Also when ever im driving it, Ill come to a stop and itll sound like its going to die and then jump up to like 1100 rpms. Any suggestions as to what that might be?
    1951 3100
    1984 C10

  2. #2
    Join Date
    Nov 2003
    Location
    Denton Texas
    Posts
    20,689
    Either a dead 02 sensor or blown fuse in the 02 heater circuit. Buy sensors for the rear 02 in a late model Corvette. Are you using a factory wiring harness or the Nelson harness?
    See my truck data in the "My Garage" section here... http://www.ls1truck.com/forums/my-ga...tml#post191709

  3. #3
    Join Date
    Nov 2003
    Location
    Denton Texas
    Posts
    20,689
    Also, check all your grounds that they are tight and wires didn't break.
    See my truck data in the "My Garage" section here... http://www.ls1truck.com/forums/my-ga...tml#post191709

  4. #4
    Join Date
    Sep 2005
    Location
    Austin Tx.
    Posts
    13,396
    I am using the factory harness. Do you know which side it is referring to that would be bad? What about the idle speed high code?
    1951 3100
    1984 C10

  5. #5
    Join Date
    Sep 2005
    Posts
    314
    Passenger side 02. Check for vaccum leak, Could cause your idle issue and 02 issue. Could be bad 02 and IAC problem carbon/dirty etc... If you have HPT, EFI or a scan tool you can command position to test IAC

  6. #6
    Join Date
    Jan 2005
    Location
    Humble/Houston TX
    Posts
    2,614
    before replacing anything get the exhaust buttoned up and some hands on tuning IMO

    old mod list: H/C/I/N/E/G 408
    new mod list: 5.3, gears/posi, mufler and tune : (

  7. #7
    Join Date
    Mar 2003
    Location
    San Marcos Texas
    Posts
    4,442
    You could also swap the o2's right and left and see if the problem moves.
    2006 Superior Blue Trailblazer SS AWD, Stock as a rock

    Sold: 2002 GMC Sportside Denali front end with a 2002 LS1, FLT level 5, Yank 2600, Trick Turbo, T76, Nelson intercooler, 60LB injectors, Warbro fuel pump, Eaton locker, Magnaflow, 3.42, Nelson Performance Tuning (speed density).

    Sold: 1981 GMC LB RC 1500 2002 4.8L 4L60E 12 bolt 3.73 Richmond Lock Right AC PS Nelson Performance tuning

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts