+ Reply to Thread
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 39

Thread: HELP!!! Truck failed inspection

  1. #11
    Join Date
    Jul 2006
    Location
    College Station, TX
    Posts
    653
    I dont understand why you cant come down here and get it inspected?
    2004 EXC Silverado 6.2L
    Mods:
    6.2L L92, Ported and Polished stage 3 heads, 95mm Throttle Body, 100mm MAF, NA, Pacesetter LT Headers, Magnaflow X-Pipe Muffler, Electric Fans, 160* thermostat, 2" Drop Shackles, Hellwig Sway Bars Front and Rear, Monroe Reflex Shocks, NGK Spark Plugs, AMW Oil Catch Can, 17"x10" wheels on Kuhmo Tires.

  2. #12
    Join Date
    Apr 2005
    Posts
    4,360
    <div class='quotetop'>QUOTE(farmtruc &#064; May 8 2007, 03&#58;25 PM) [snapback]92713[/snapback]</div>
    SC, hopefully some drive time like Red said will do the trick.

    As far as I know, you&#39;re allowed to fail two of the seven ready state tests. Ready state tests are different from SES lights. SES lights are faults in the system and the ready state test is an evaluation of the entire system. Before some tests pass, others have to pass, so driving is the only way to have these tests at Ready.
    keep us updated,
    allen
    [/b]
    I hit 150 miles today with no SES lights, so hopefully it will pass tomorrow or Thursday.

    I think you have to get it inspected in the county you are registered in. On top of that, my county is an emissions county.
    Gone, but not forgotten!

  3. #13
    Join Date
    Dec 2003
    Location
    Azle,TX
    Posts
    3,766
    <div class='quotetop'>QUOTE(SCIV &#064; May 8 2007, 08&#58;17 PM) [snapback]92754[/snapback]</div>
    I hit 150 miles today with no SES lights, so hopefully it will pass tomorrow or Thursday.

    I think you have to get it inspected in the county you are registered in. On top of that, my county is an emissions county.
    [/b]
    The county on the tags must match the inspecting county...I think thats the way it goes
    Vortec Performance Tuned
    LQ9 built 4L60 LTs and a billion miles on the speedo!

  4. #14
    Join Date
    Apr 2005
    Posts
    4,360
    F*&&#33; me. I put 220 miles on it of mostly stop & go city driving. Longest run of about 20 minutes/miles.

    It failed reinspection. Still failed with not ready on Evap & O2&#39;s. They said you can fail 2 "Not Ready", but not 3. Please help me&#33;&#33;
    Gone, but not forgotten!

  5. #15
    Join Date
    Nov 2003
    Location
    Denton Texas
    Posts
    20,689
    That sucks. What&#39;s the deal with the evap? Is it not turned off in the PCM tune? Did they say if it was the front or rear O2 sensors that aren&#39;t ready? I&#39;ve been told to drive on the highway prior to the inspection, that will get the sensors up to temp by at least the exhaust temp do the work.
    See my truck data in the "My Garage" section here... http://www.ls1truck.com/forums/my-ga...tml#post191709

  6. #16
    Join Date
    Sep 2005
    Posts
    314
    Dude&#33; Check your Tune, Get with your tuner or someone who can help you with a tuning suite. In HPT for example "SES" MUST BE TO ENABLED&#33; "ERROR REPORT" HAS TO BE ON #3 (NO ERROR REPORTED) Its full proof and you will never pass without this&#33; This is your issue, You complete some drive cycles.

    good luck, Sorry about the caps

  7. #17
    Join Date
    Sep 2005
    Posts
    314
    To complete a drive cycle of the H02S there must be an ECT reduction of 18 deg F from the end of the last ignition cycle. Start the engine and and idle for 2 minutes or until the test updates... Can take 8 mins so do this.

    The Evap is alittle tricky as its Drive cycle is done from a cold start. The PCM considers a cold start to be ECT and IAT 41-86 Deg F. and the differnce between ECT and IAT < 14 Deg.

    To complete a Evap drive cycle.. Start enngine and allow to idle... Accelerate at part throttle to 45 MPH and maintain speed until engine reaches operating temp. This may take 8-20 mins. The continue for 3 or more minutes to update Evap monitor.

    This is a tune issue if you have deleted these things, What was the third fail?

    -moto

  8. #18
    Join Date
    Apr 2005
    Posts
    4,360
    Same stuff failed as in my first post. My stomach hurts.
    Gone, but not forgotten!

  9. #19
    Join Date
    Sep 2005
    Location
    Austin Tx.
    Posts
    13,396
    Talk to Red03silSS SC..
    1951 3100
    1984 C10

  10. #20
    DBYRD Guest
    pay off the guy slip him a bill or two. that sucks i hope we never go to emissions county BS.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts