+ Reply to Thread
Results 1 to 3 of 3

Thread: 4l60e NOT FULLY ENGAGING INTO REVERSE

  1. #1
    Join Date
    Dec 2014
    Location
    Washington
    Posts
    4

    Wink 4l60e NOT FULLY ENGAGING INTO REVERSE

    Hows it going folks i have a 1993 Sierra Stepside (lq9) matted to the older 4l60e transmission that came original in the truck, just had the transmission rebuilt with the Pro Street Kit from Pro Automatics, everything has been run through, valve body solenoids etc everything seems to be good. even replaced the converter with an OEM (for now), although i am having problems with the reverse fully engaging, everything else works great

    if anyone out there could help me it would be greatly apreciated, thank you!
    Attached Images

  2. #2
    Join Date
    Dec 2014
    Location
    Washington
    Posts
    4
    IMG_20141230_213808.jpg

    if you have any other recommendations, besides what could be the problem, as to improve the performance and life the the tranny feel free to drop a line i am a newbie in this. i will be upgrading the stall with one from precision industries, i don't know what I'm going to go with just yet all i do know is that i will be supercharging the truck with the magnuson tvs 1900 kit, and am running a 3.73 gearing with 26 tall rallys as in the picture attactched, if anyone can help it will be greatly appreciated thank you!
    Last edited by alumbrado93; 01-04-2015 at 10:38 AM.

  3. #3
    Join Date
    Aug 2011
    Location
    New Port Beach, CA.
    Posts
    54
    Ha if your going to put a blower on it i would swap the tranny to a stock 4l80e, have nelson performance right you a tune and be done with it. The 4l60e behind a blown 6.0 is going to burn up no matter what you do to it. Good luck with the truck sounds like its gonna rip.
    6.0 MAX Blown

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts