+ Reply to Thread
Results 1 to 3 of 3

Thread: Plug on the back, on top of the engine. Use the old 3 wire or new 1 wire?

  1. #1
    Join Date
    May 2009
    Posts
    11

    Oil Pressure Sensor on top of the engine on the Drivers Side

    Hi everyone. I am almost done with the LS Swap on my 97 2 door.

    On the back of the engine up top on the drivers side, there is what I am guessing is the oil pressure sensor. The plug on the 97 has 3 wires...




    The plug on the LS engine only has one wire...



    The harness will be wired differently depending on what sensor is used.

    I'm not using the computer from the 97. Only the computer from the 02.

    Do I need to use the old sensor so the gauge on the dash reads correct?
    Last edited by lovesdunes; 03-25-2019 at 06:21 PM.

  2. #2
    Join Date
    Sep 2011
    Posts
    264
    You will need to adapt the stock sensor to your new engine so that you will get correct oil pressure reading in the dash, retain the plug from the 97 as well

  3. #3
    Join Date
    May 2009
    Posts
    11
    Quote Originally Posted by 1991SSP View Post
    You will need to adapt the stock sensor to your new engine so that you will get correct oil pressure reading in the dash, retain the plug from the 97 as well
    Thank you for the reply. I was thinking I needed to use the old sensor and plug, but for some reason when I modified my harness I used the new sensor and plug. Yesterday while checking wires I found two loose wires looking for a home on the old sensor. Good Times LOL

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts