+ Reply to Thread
Results 1 to 10 of 10

Thread: Adapting oil cooler lines to radiator

  1. #1
    Join Date
    Sep 2011
    Posts
    252

    Adapting oil cooler lines to radiator

    Anyone know what adapters are needed to adapt the stock oil cooler lines from the LQ4 engine to the stock OBS radiator?

  2. #2
    Join Date
    Mar 2015
    Posts
    6
    They threaded right in for me. I ended up replacing them with an fittings and -6 hose because the old lines started leaking. I might have had to use new o rings.

  3. #3
    Join Date
    Sep 2011
    Posts
    252
    I had oil lines with the push type connectors,,, found out tonight that they would not work.. lines hit the motor mount.. I'll look into other options

  4. #4
    Join Date
    Mar 2015
    Posts
    6
    Yup mine were the same connectors. The piece that you push into can unthread from the radiator. If they are the cooler lines that came with that lq4 they should snake right around the mount. Maybe I'm missing something. I spent about 120$ on fittings and hose to run new cooler lines.

  5. #5
    Join Date
    Mar 2015
    Posts
    6
    I got to thinking if you're trying to install the lines after the engine is in it's a pita. You would have to unbolt the motor mount and jack up the drivers side to sneak the hard lines behind the mount. There is no way you could thread them through with all the bends they have.

  6. #6
    Join Date
    Sep 2011
    Posts
    252
    my truck is a c3500.. I have no problems getting the lines through... the problem is with the part of the motor mount that is welded to the frame,, thats what the lines are hitting... I used dirty dingo mounts to install my engine onto the stock lower mounts on my truck

  7. #7
    Join Date
    Mar 2015
    Posts
    6
    I used the dirty dingo adjustable also. So are you using the lq4 oil cooler lines? They tucked between the mount and the block on my set up

  8. #8
    Join Date
    Sep 2011
    Posts
    252
    yes, they were hanging on my engine when I got it...if they do in fact go in between the mount and the block then you are 100% correct. they will not fit..... I will take a closer look.

    I may just take that side loose and put them back on...

  9. #9
    Join Date
    Mar 2015
    Posts
    6
    Yup and there is a clamp just in front of the mount to keep the lines tight.

  10. #10
    Join Date
    Sep 2011
    Posts
    252
    I have to recall my comment,, on a C3500 the oil cooler lines WILL NOT work..the C3500 frame has stand offs from the factory that the lower mounts bolt to,,, the oil line hits this part of the stand off and will not mount up on my truck
    Last edited by 1991SSP; 03-05-2017 at 04:11 PM.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts