+ Reply to Thread
Results 1 to 4 of 4

Thread: 80's c-10 swap faq maybe a sticky???

  1. #1

    80's c-10 swap faq maybe a sticky???

    OK I have poured through the threads trying to piece together everything I could to suit my setup and I understand that every case is different. The burning questions that remain for me have already been answered but need clarification.

    I have an 84 c10 swb. It has a tilt with cruise and headlight dimmer on the steering column.

    I think that i am understanding all I will have to do is find the wire in the harness and run it to the ignition wire in the column and we have fire?

    then my temp and oil gauge on the 5.3 will hook to the old school harness and work? and throw no codes?

    I thought you could run a non electric transmission but nelson performance says no with their harness??

    If you do have to run an electric transmission .....you have to get a gauge panel from a ?? 91 burban??

    A/C is another issue--- do I have to get a late model A/C control unit for my dash or will my old school one just hook right up? and then what about engine idle up when the A/C comes on or WOT?

    I am really impressed with the knowledge on this site it is just so hard for me to dig through all of this and answer those questions. I am not afraid to cut the frame and do the install and buy a new driveshaft but the wiring is scaring me to death because when I start this I will have about 1 week to be back on the road again and cant afford to miss anymore than that. I have found a good used junkyard motor tranny and harness with pcm and would like to keep with the cheapest parts I can and upgrade from there later. I have devoted 3500 for this project motor tranny exhaust and wiring.

    Thanks for any help I can get and I hope this will turn into an informative thread for anyone else doing a swap into a like model truck.
    Last edited by mercuno; 01-18-2010 at 01:38 AM.

  2. #2
    Join Date
    Aug 2009
    Posts
    121
    1/
    your wiring should hook up from the block on the inside of the engine bay theres about 3-4 wires needed from there !! i never touched my column to make the engine fire
    2/
    the temp and oil gauges require you to use adapters the first is the oil it gonna be located on the drivers side oil pan area there is a block with 2 ten mil bolts you remove the block and drill and tap a tread to install your factory gauge !
    the temp located rear PASS side head its has a bung remove the bung and repace it with the adapter from s&p there like $18 install your temp sender both gauges use your fatory wiring !!!
    3/
    some harness builder can make harness without elec.trans there is some VSS issues i SOLD my 700r4 and ran a 4l60e problem solved

    4/
    if you run a elec speedo you can get an expensive modded output shaft housing with a cable drive or run a burb speedo thats what i did!! the harness will come with a single wire for the speedo and tacho its easy

    5/
    a/c sorry i dont have it

    6/ $3500 is more than enough for a standard install

    http://www.youtube.com/watch?v=qjcgXHjyChg
    Last edited by aussie; 01-18-2010 at 09:32 AM.

  3. #3

    Thumbs up

    what did you do for fuel pump? just drop a walbro in?
    thanks for the reply summed it up real nice love your video

  4. #4
    Join Date
    Aug 2009
    Posts
    121
    no i used a airtex fuel pump E3270 provides plently of PSI $79.99 AutoZone
    you will see in the 8th post on the link below ! this is what i did to my truck its imformation i sent to oldyeller
    http://www.ls1truck.com/forums/lsx-t...ns-85-p-u.html
    if you have any questions hit me back!!!!

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts