+ Post New Thread
Page 3 of 41 FirstFirst 1 2 3 4 5 13 ... LastLast
Threads 41 to 60 of 817

Forum: Diagnostics & Troubleshooting

Powertrain | Performance | Electrical |

  1. 6.0 lifter tick help needed..

    I replaced the 4.8 with a 6.0 with 130k on it from a 2004 yukon into my 1999 ecsb 4x4. I love it and it runs awesome! Its been in there for around...

    Started by mopower440‎, 04-10-2015 06:54 PM
    • Replies: 4
    • Views: 1,104
    04-14-2015, 11:54 PM Go to last post
  2. Bad fuel pump?

    So I was cleaning up some wiring today, making sure everything works, and I found my fuel pump is inop. (89 K1500) I have power going to the relay,...

    Started by Cardot60‎, 04-12-2015 09:56 PM
    • Replies: 2
    • Views: 760
    04-13-2015, 09:56 PM Go to last post
  3. Hardest truck you have diagnosed...and fixed

    We got this truck here and it's probaly one of the top ten trucks we have diagnosed. No truck is hard to figure out some are just more time...

    Started by farmtruc‎, 04-05-2015 11:39 PM
    2 Pages
    1 2
    • Replies: 10
    • Views: 1,803
    04-10-2015, 10:56 PM Go to last post
  4. Throttle body actuator

    I have an 05 rcsb with a 4.8, Nelson tuned. Cai. BBK throttle body. Truck runs great but when it comes to an idle sometimes dips to 300 rpm or so....

    Started by allnitelong‎, 04-01-2015 07:25 AM
    • Replies: 2
    • Views: 630
    04-01-2015, 06:28 PM Go to last post
  5. coolant hose replacement necessary?

    I have a 1999 ecsb 4x4 with the 4.8. It now has 236,000 miles on it. I had one of the heater hose quick connects blow out on me yesterday, luckily i...

    Started by mopower440‎, 03-30-2015 09:10 PM
    • Replies: 0
    • Views: 643
    03-30-2015, 09:10 PM Go to last post
  6. 2014 dash rattle

    Does anyone else on here with a 2014 or 2015 Silverado or sierra have a rattle in the dashboard coming from the plastic panel that houses the...

    Started by medic2901‎, 02-01-2015 10:19 PM
    • Replies: 2
    • Views: 3,070
    03-26-2015, 06:31 PM Go to last post
  7. P0327 p0332 knock sensor codes help!!!

    Hey guys I have a 02 2500hd. I have code 327 and 332 after washing engine. I replaced both knock sensors and the harness but the codes both come...

    Started by johnmichael397‎, 02-23-2015 08:28 PM
    • Replies: 2
    • Views: 905
    02-24-2015, 04:46 PM Go to last post
  8. bellhousing bolt size?

    1999 4.8 engine, anyone kn ow off hand what size the bolts are that hold the bellhousing to the engine? I have to pick some up to bolt the 4.8 to the...

    Started by mopower440‎, 02-20-2015 08:20 PM
    • Replies: 1
    • Views: 774
    02-23-2015, 01:44 PM Go to last post
  9. ls swap 5.3 on obs cracked oil pan

    Alright so this past sat I hit a huge pothole in these f*** up Houston streets and I believe I damaged my oil pan pretty bad could that cause the...

    Started by Maverick‎, 02-16-2015 10:15 AM
    • Replies: 6
    • Views: 1,166
    02-16-2015, 08:20 PM Go to last post
  10. water in pcm harness..

    I somehow keep getting water in my pcm harness on the blue side. It keeps causing my fans to kick on even when truck is not running and drains my...

    Started by NoTaTurBo‎, 11-25-2013 09:58 AM
    • Replies: 2
    • Views: 1,377
    02-10-2015, 10:29 PM Go to last post
  11. Lights and Gauges Issue LS Swap

    So we got my truck finished and running, a few little things. My builder wasnt able to get my lights, ( headlights, lamps, inside, gauge cluster...

    Started by LQ4Javi‎, 02-02-2015 12:09 AM
    • Replies: 4
    • Views: 1,072
    02-02-2015, 09:16 PM Go to last post
  12. Transmission problems?

    So I own a 2003 silverado that originally came with a 4.3,I converted it to a 5.3 out of 2004. The engine came with the harness and computer. I had...

    Started by SageB82‎, 11-20-2014 12:50 PM
    2 Pages
    1 2
    • Replies: 15
    • Views: 3,332
    01-26-2015, 10:14 PM Go to last post
  13. Angry Weird pulsating in brake pedal

    I Hey folks After searching around for the last couple nights I've come to the conclusion that it was time to get your guys opinion. I have an 04...

    Started by CaptTrevStarr‎, 01-22-2015 07:11 PM
    • Replies: 2
    • Views: 640
    01-24-2015, 11:47 AM Go to last post
  14. Strange high rpm miss

    I have a 5.3 T56 conversion in a 92 full size. The truck has had the engine transmission in its current state for a few years and has been 100%...

    Started by pnhigg‎, 01-06-2015 07:53 AM
    • Replies: 1
    • Views: 745
    01-07-2015, 09:59 AM Go to last post
  15. No accelerator pedal on 5.3 swap

    I am recently finishing up my 4.3 5 speed to a 5.3 auto swap and the truck is running and everything is working except the gas pedal any advice would...

    Started by rcsbssclone‎, 01-02-2015 09:08 AM
    • Replies: 2
    • Views: 737
    01-02-2015, 01:59 PM Go to last post
  16. vibration at high speeds

    hey guys i have a 2005 chevy 1500 ss all wheel drive i have a bad vibraton at 90 plus when you throttle hard you can feel it in foot pedal and...

    Started by chevyss1500‎, 12-29-2014 07:13 PM
    • Replies: 0
    • Views: 514
    12-29-2014, 07:13 PM Go to last post
  17. Truck just died

    I had a 2002 Chevy z71. I sold it too a guy and he drove a 100 miles and the truck just died going down the road. I have had the truck for 2 years...

    Started by heavy_chevy_07‎, 12-27-2014 12:24 PM
    • Replies: 1
    • Views: 618
    12-27-2014, 12:58 PM Go to last post
  18. 4x4 live axle conversion monster

    I just finished my live axle conversion on my truck. It took a little bit of time and hunting for parts. I used a dodge aam front axle with custom...

    Started by jaysonolson‎, 11-25-2014 03:03 AM
    • Replies: 0
    • Views: 721
    11-25-2014, 03:03 AM Go to last post
  19. My Five three won't start on its own!

    I've got a 94 silverado that I dropped a five three 4l80e combo I can't seem to fire up on its own. The walbro pump is working I've got 49 psi at the...

    Started by TruckinthruTexas‎, 11-20-2014 08:07 PM
    • Replies: 0
    • Views: 590
    11-20-2014, 08:07 PM Go to last post
  20. Oil leak...but where?

    I noticed a few drops of engine oil on the garage flood today. Climbed under the truck and snapped some pics. I can't tell where its coming from. Oil...

    Started by Robt34‎, 11-11-2014 07:43 PM
    • Replies: 9
    • Views: 1,944
    11-20-2014, 03:23 PM Go to last post

+ Post New Thread

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts