+ Reply to Thread
Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 54

Thread: Eaton Charger + AFM (DoD) removal issue

  1. #1
    Join Date
    Mar 2003
    Location
    San Antonio, TX
    Posts
    11,117

    Eaton Charger + AFM (DoD) removal issue

    Hey guys.

    Kind of a troubleshooting post, but does involve dod delete and an eaton (tvs) charger.

    Gotta 2011 truck, 5.3L, 6speed auto.

    Removed the heads and got rid of those DoD lifters. Install went fine.
    Installed a charger.

    Truck originally was calibrated for DoD.
    On all the other years 2010 and earlier, we simply physically remove the DoD parts and turn off the codes, everything always works great!

    On this particular truck, did the same thing and now the truck is stuck in DoD mode for some reason.

    Tried:
    -switching off DoD in pcm
    -turned off codes
    -used another 2011/2010 4.8L ecm code with no DoD
    -used another ecm with same code, just to make sure
    -used a 2008 ecm, 6L with no DoD

    The engine is still stuck in DoD mode. cylinders 1,4,6,7 are misfiring.

    any input is appreciated,

    allen

  2. #2
    Join Date
    Mar 2011
    Location
    rgv
    Posts
    50
    Talk to dealership guy???? Maybe needs some type of reflash by them

  3. #3
    Join Date
    Mar 2003
    Location
    San Antonio, TX
    Posts
    11,117
    Quote Originally Posted by 8-ball View Post
    Talk to dealership guy???? Maybe needs some type of reflash by them
    As far as dealerships are concerned, there's no way they'd touch this. Plus, we have all the tools the dealer has, applications, scanners, flashing, updates, etc.

    thansk

  4. #4
    Join Date
    Mar 2011
    Location
    rgv
    Posts
    50
    Can't think of anything that it could be?

  5. #5
    Join Date
    Nov 2009
    Location
    SAN ANTONE
    Posts
    784
    all the criteria is being met for AFM to take over at idle and during cruising speed, will not come out of v4 mode
    06 rcsb, 6two, 231/235, 4.11, pacesetter, 80e, 14 bolt, Nelson tuned
    2011 rcsb 6two swap in the works with 6l90 and boost
    FARMTRUC CAN GARGLE PEANUT BUTTER

  6. #6
    Join Date
    Jan 2008
    Posts
    8,203
    that sux

  7. #7
    Join Date
    Mar 2007
    Posts
    1,729
    Got a Friend in Australia, that upgrade cam, box and converter, and is in your same situation.

    He programs with HPtuners. No solution ti'll now.

    I'll ask him if he did some advances there !

  8. #8
    Join Date
    Mar 2003
    Location
    San Antonio, TX
    Posts
    11,117
    Quote Originally Posted by 2boostedSilverado View Post
    Got a Friend in Australia, that upgrade cam, box and converter, and is in your same situation.

    He programs with HPtuners. No solution ti'll now.

    I'll ask him if he did some advances there !
    ok good to know. another person told me he's having the same issue.

  9. #9
    Join Date
    May 2008
    Location
    Crossett,Ar
    Posts
    2,461
    Quote Originally Posted by farmtruc View Post
    ok good to know. another person told me he's having the same issue.
    That's odd. Are there any sensors that control when it goes into dod? Maybe a override to the tune? Sounds electric if u have removed all dod hardparts for sure...

  10. #10
    Join Date
    Mar 2003
    Location
    San Antonio, TX
    Posts
    11,117
    Quote Originally Posted by Show&Go View Post
    That's odd. Are there any sensors that control when it goes into dod? Maybe a override to the tune? Sounds electric if u have removed all dod hardparts for sure...
    The DoD is activated by the PCM when all the variables, based on load, speed, tps, engine run time, temperature, rpm, etc are met. So, bascially, DoD is activated with very light throttle only.

    Those cylinders aren't completely dead, they are working, but they are still missing and the truck has an unacceptable idle, but not rough.

    There arent any sensors that control anything mechanical, they are used to sense things and report to the pcm, then the pcm controls DoD by activating the DoD system.

    This is a tough one.

    Only thing we haven't tried so far, is another 2011 pcm with the same 5.3L tune on it, maybe it's a bad ecm. We've tried different OS's in the same 2011 ecm, but not an ecm.
    The 2008 ecm was just funky and the truck didn't like that one at all.
    Last edited by farmtruc; 05-16-2011 at 03:19 PM.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts