+ Post New Thread
Page 1 of 40 1 2 3 11 ... LastLast
Threads 1 to 20 of 800

Forum: Diagnostics & Troubleshooting

Powertrain | Performance | Electrical |

  1. Sticky Thread Sticky: Crankshaft System Variation Learn Procedure

    The CKP System Variation Learn procedure concerning the relationship of the Crankshaft Postion Sensor, or CKP, to the crankshaft reluctor was...

    Started by RedHeartbeat‎, 09-16-2007 01:31 PM
    3 Pages
    1 2 3
    • Replies: 24
    • Views: 13,533
    10-29-2009, 11:40 PM Go to last post
  2. Sticky Thread Sticky: Idle Learn Procedure

    The Idle Learn procedure may be required when: 1.) The PCM loses power or ground (battery or PCM disconnected) 2.) Service programming is performed...

    Started by RedHeartbeat‎, 09-16-2007 01:02 PM
    • Replies: 0
    • Views: 5,215
    09-16-2007, 01:02 PM Go to last post
  1. 5.3 oil pan cracks

    I am in the process of removing the sludge from my 5.3 2004 Tahoe. My castech heads went bad around 130K. I pulled my oil pan and noticed there are...

    Started by Gooman‎, 03-06-2017 08:00 PM
    • Replies: 0
    • Views: 196
    03-06-2017, 08:00 PM Go to last post
  2. 01 silverado 4.8 engine has miss

    I just bought a nice 01` shortbed with 200k seems to run ok but has a shake in engine po300 code and po308 put new plugs and wires ,switched coil...

    Started by oldman‎, 12-12-2016 06:30 PM
    • Replies: 3
    • Views: 736
    12-25-2016, 08:00 PM Go to last post
  3. 2wd to awd coversion

    I have a 02 Denali for donor awd 6.0 of course I want my 05 rcsb 4.3/5spd to be converted to awd 6.0 auto. Has anyone here done this. I...

    Started by FastSierra05‎, 08-14-2016 02:43 PM
    • Replies: 3
    • Views: 536
    11-20-2016, 01:34 AM Go to last post
  4. 2003 chevy silve. 6.0l engine with gt2-3 cam and zo6 comp springs slit bumb in idle.

    He guys so I had a 2003 denali 6.0 lq4 complete remand done with a few modes. first valve job with zo6 beehive comp valve springs and push rods, gmpp...

    Started by jaysonolson‎, 10-24-2016 03:20 AM
    hesitation, motor bumping, smell of fuel
    • Replies: 1
    • Views: 215
    11-20-2016, 01:18 AM Go to last post
  5. Post Perhaps Too Much Fuel Pressure?

    I still have, for the most part, a stock 5.3 from a 2008 Tahoe in my 88 K5 Blazer, so we're talking 330 to 350hp at most. I do have some JBA headers...

    Started by 88blazerboy‎, 01-09-2016 11:02 AM
    2 Pages
    1 2
    • Replies: 10
    • Views: 1,272
    10-28-2016, 11:55 PM Go to last post
  6. Ls obs ac signal??

    I've had my truck swapped with a h/c/i 5.3 for a while now and have driven it everywhere with no real issues....aside from these 2 and I've had...

    Started by Jmac527‎, 07-11-2016 12:13 AM
    • Replies: 2
    • Views: 489
    10-26-2016, 02:49 PM Go to last post
  7. O4 5.3 in 99 silverado 3500. Engine runs now need help with gauges.

    Truck is a 99 "classic" body style 3500 with 5 speed manual.4x4. I need help getting the speedo, coolant temp, and oil pressure to work. Any help is...

    Started by Jfish‎, 10-23-2016 07:54 PM
    • Replies: 0
    • Views: 88
    10-23-2016, 07:54 PM Go to last post
  8. O2 sensors...UGHHHHHHH

    I'll make this brief. Did LS 4.8 swap, engine, trans, harness and all as unit from donor vehicle Into my 91 Silverado. Replaced harness with a unit...

    Started by L8RH8R‎, 04-21-2016 06:01 PM
    2 Pages
    1 2
    • Replies: 17
    • Views: 1,833
    09-23-2016, 07:56 AM Go to last post
  9. Engine Tick

    After 1200 miles on my lq9 swap my engine developed a metallic tick. The sound only becomes noticeable around 190-200 degrees. My thoughts were a bad...

    Started by Gemini‎, 02-16-2016 06:47 PM
    • Replies: 7
    • Views: 1,131
    05-07-2016, 11:59 AM Go to last post
  10. No Brakes

    So I have got my 4.8L Ls swap running in my 1996 C1500. I removed the old PCM for the 4.3v6. I am wondering if I am missing something to get my...

    Started by Safariwagon‎, 04-20-2016 05:14 AM
    • Replies: 3
    • Views: 344
    04-26-2016, 11:59 AM Go to last post
  11. 07 gmt900 wiring diagrams?

    So been a while since i have posted, projects went away and life happened. Anyway, i'm experiencing problems with my 07 gmt900's transmission where...

    Started by 60ratrod‎, 01-30-2016 12:33 PM
    • Replies: 0
    • Views: 379
    01-30-2016, 12:33 PM Go to last post
  12. possible 4l80e problems after HD-2 shift kit install

    Installed the transgo shift kit in my 4l80e and I'm not sure if its working right. I have done shift kits before and they would shift firm and hard....

    Started by JoshB‎, 10-02-2010 07:27 PM
    • Replies: 5
    • Views: 3,851
    01-21-2016, 04:36 PM Go to last post
  13. Unhappy MAF Sensor question (I know it's not exciting)

    I swapped an 02 4.8 and 4l60e trans into my 91. After pulling my hair out over other issues, the truck still runs rich and is a slug from a dead...

    Started by L8RH8R‎, 01-04-2016 09:33 AM
    • Replies: 3
    • Views: 626
    01-05-2016, 01:05 PM Go to last post
  14. Engine dies on deceleration after warm up

    I have a 5.3 that I swapped into my obs I put an ls6 intake on the engine and swapped the cam. I did have the ecm tuned for the cam. (mail order) ...

    Started by slicpartna‎, 12-01-2015 07:29 PM
    • Replies: 3
    • Views: 844
    12-12-2015, 11:50 AM Go to last post
  15. Possible fuel issue?

    I will try to be as brief as possible. 91 Silverado with 02 4.8 swap. After first several attempts to start, engine ran (each time I tried to crank...

    Started by L8RH8R‎, 10-05-2015 09:49 PM
    2 Pages
    1 2
    • Replies: 14
    • Views: 2,784
    11-26-2015, 03:37 PM Go to last post
  16. Fuel pressure regulator

    Still having issues with mine cold starting, so I changed the fuel pressure regulator and now I have this buzzing/vibrating sound?

    Started by Esky02‎, 11-23-2015 02:28 PM
    • Replies: 0
    • Views: 438
    11-23-2015, 02:28 PM Go to last post
  17. ECM question

    Hey guys it's been awhile since I've posted anything. I recently picked up a 2001 1500HD with the 6.0. The motor was bad but guy had bought another...

    Started by Esky02‎, 11-17-2015 06:57 PM
    • Replies: 2
    • Views: 568
    11-18-2015, 01:32 PM Go to last post
  18. 6.0 swap ecm code U0100 need help I'm new here

    I did a 6.0 swap engine runs fine no check engine light but when you hook the truck up it has a u0100 code stored could this be a tuning issue.

    Started by AB076.oh‎, 09-03-2015 11:46 AM
    • Replies: 2
    • Views: 1,182
    09-03-2015, 01:41 PM Go to last post
  19. For the a/c gurus

    So attached is a 94 a/c circuit wiring diagram. The only portions i am worried about is the compressor circuit. So the blue dashed wire (may not be...

    Started by creekrat‎, 08-16-2015 01:44 AM
    • Replies: 1
    • Views: 1,315
    08-16-2015, 09:28 AM Go to last post
  20. Thermostat retune?

    I had a 160 Stat that was getting stuck open so I put a stock one back in. Had it tuned for the 160. Will I need to get a retune for fan speed or...

    Started by SShanks‎, 08-12-2015 01:42 AM
    • Replies: 0
    • Views: 349
    08-12-2015, 01:42 AM Go to last post

+ Post New Thread

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts